| <testcase> | |
| <info> | |
| <keywords> | |
| SMTP | |
| SASL | |
| SASL AUTH OAUTH2 | |
| RFC4954 | |
| RFC6749 | |
| RFC7628 | |
| </keywords> | |
| </info> | |
| # | |
| # Server-side | |
| <reply> | |
| <servercmd> | |
| AUTH OAUTHBEARER | |
| REPLY AUTH 334 OAUTHBEARER supported | |
| REPLY %b64[n,a=user,%01host=127.0.0.1%01port=%SMTPPORT%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% 334 eyJzdGF0dXMiOiJpbnZhbGlkX3Rva2VuIiwic2NvcGUiOiJleGFtcGxlX3Njb3BlIiwib3BlbmlkLWNvbmZpZ3VyYXRpb24iOiJodHRwczovL2V4YW1wbGUuY29tLy53ZWxsLWtub3duL29wZW5pZC1jb25maWd1cmF0aW9uIn0 | |
| REPLY AQ== 535 Username and Password not accepted. Learn more at\r\n535 http://support.example.com/mail/oauth | |
| </servercmd> | |
| </reply> | |
| #vi | |
| # Client-side | |
| <client> | |
| <server> | |
| smtp | |
| </server> | |
| <name> | |
| SMTP OAuth 2.0 (OAUTHBEARER) failure as continuation | |
| </name> | |
| <stdin> | |
| mail body | |
| </stdin> | |
| <command> | |
| smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt recipient@example.com --mail-from sender@example.com -u user --oauth2-bearer mF_9.B5f-4.1JqM -T - | |
| </command> | |
| </client> | |
| # | |
| # Verify data after the test has been "shot" | |
| <verify> | |
| # 67 - CURLE_LOGIN_DENIED | |
| <errorcode> | |
| 67 | |
| </errorcode> | |
| # | |
| # The multi interface considers a broken "CONNECT" as a prematurely broken | |
| # transfer and such a connection will not get a "QUIT" | |
| <protocol> | |
| EHLO %TESTNUMBER | |
| AUTH OAUTHBEARER | |
| %b64[n,a=user,%01host=127.0.0.1%01port=%SMTPPORT%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% | |
| AQ== | |
| </protocol> | |
| </verify> | |
| </testcase> |