| <testcase> | |
| <info> | |
| <keywords> | |
| POP3 | |
| SASL | |
| SASL AUTH OAUTH2 | |
| RFC1734 | |
| RFC5034 | |
| RFC6749 | |
| RFC7628 | |
| </keywords> | |
| </info> | |
| # | |
| # Server-side | |
| <reply> | |
| <servercmd> | |
| AUTH OAUTHBEARER | |
| REPLY AUTH + | |
| REPLY %b64[n,a=user,%01host=127.0.0.1%01port=%POP3PORT%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% +OK Login successful | |
| </servercmd> | |
| <data> | |
| From: me@somewhere | |
| To: fake@nowhere | |
| body | |
| -- | |
| yours sincerely | |
| </data> | |
| </reply> | |
| # | |
| # Client-side | |
| <client> | |
| <server> | |
| pop3 | |
| </server> | |
| <name> | |
| POP3 OAuth 2.0 (OAUTHBEARER) authentication | |
| </name> | |
| <command> | |
| pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user --oauth2-bearer mF_9.B5f-4.1JqM | |
| </command> | |
| </client> | |
| # | |
| # Verify data after the test has been "shot" | |
| <verify> | |
| <protocol> | |
| CAPA | |
| AUTH OAUTHBEARER | |
| %b64[n,a=user,%01host=127.0.0.1%01port=%POP3PORT%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% | |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| </verify> | |
| </testcase> |