| <testcase> | |
| <info> | |
| <keywords> | |
| POP3 | |
| SASL | |
| SASL AUTH DIGEST-MD5 | |
| SASL CANCELLATION | |
| RFC1734 | |
| RFC2831 | |
| RFC5034 | |
| </keywords> | |
| </info> | |
| # | |
| # Server-side | |
| <reply> | |
| <servercmd> | |
| AUTH DIGEST-MD5 | |
| REPLY AUTH + Rubbish | |
| REPLY * -ERR AUTH exchange cancelled by client | |
| </servercmd> | |
| </reply> | |
| # | |
| # Client-side | |
| <client> | |
| <server> | |
| pop3 | |
| </server> | |
| <features> | |
| !SSPI | |
| Debug | |
| crypto | |
| </features> | |
| <name> | |
| POP3 DIGEST-MD5 graceful cancellation | |
| </name> | |
| <command> | |
| pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user:secret | |
| </command> | |
| </client> | |
| # | |
| # Verify data after the test has been "shot" | |
| <verify> | |
| # 67 - CURLE_LOGIN_DENIED | |
| <errorcode> | |
| 67 | |
| </errorcode> | |
| # | |
| # The multi interface considers a broken "CONNECT" as a prematurely broken | |
| # transfer and such a connection will not get a "QUIT" | |
| <protocol> | |
| CAPA | |
| AUTH DIGEST-MD5 | |
| * | |
| </protocol> | |
| </verify> | |
| </testcase> |