| <testcase> | |
| <info> | |
| <keywords> | |
| POP3 | |
| SASL | |
| SASL AUTH OAUTH2 | |
| SASL-IR | |
| RFC1734 | |
| RFC5034 | |
| RFC6749 | |
| </keywords> | |
| </info> | |
| # | |
| # Server-side | |
| <reply> | |
| <servercmd> | |
| AUTH XOAUTH2 | |
| REPLY AUTH +OK Login successful | |
| </servercmd> | |
| <data> | |
| From: me@somewhere | |
| To: fake@nowhere | |
| body | |
| -- | |
| yours sincerely | |
| </data> | |
| </reply> | |
| # | |
| # Client-side | |
| <client> | |
| <server> | |
| pop3 | |
| </server> | |
| <name> | |
| POP3 OAuth 2.0 (XOAUTH2) authentication with initial response | |
| </name> | |
| <command> | |
| pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user --oauth2-bearer mF_9.B5f-4.1JqM --sasl-ir | |
| </command> | |
| </client> | |
| # | |
| # Verify data after the test has been "shot" | |
| <verify> | |
| <protocol> | |
| CAPA | |
| AUTH XOAUTH2 dXNlcj11c2VyAWF1dGg9QmVhcmVyIG1GXzkuQjVmLTQuMUpxTQEB | |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| </verify> | |
| </testcase> |