| <testcase> | |
| <info> | |
| <keywords> | |
| POP3 | |
| SASL | |
| SASL AUTH DIGEST-MD5 | |
| RFC1734 | |
| RFC2831 | |
| RFC5034 | |
| </keywords> | |
| </info> | |
| # | |
| # Server-side | |
| <reply> | |
| <servercmd> | |
| AUTH DIGEST-MD5 | |
| REPLY AUTH + cmVhbG09ImN1cmwiLG5vbmNlPSI1MzAwZDE3YTFkNjk1YmQ0MTFlNGNkZjk2Zjk1NDhjMjNjZWQ2MTc1IixhbGdvcml0aG09bWQ1LXNlc3MscW9wPSJhdXRoIg== | |
| REPLY dXNlcm5hbWU9InVzZXIiLHJlYWxtPSJjdXJsIixub25jZT0iNTMwMGQxN2ExZDY5NWJkNDExZTRjZGY5NmY5NTQ4YzIzY2VkNjE3NSIsY25vbmNlPSIzNDMzMzIzMTM1MzMzMjMxMzYzMzMyMzEzNzMzMzIzMSIsbmM9IjAwMDAwMDAxIixkaWdlc3QtdXJpPSJwb3AvMTI3LjAuMC4xIixyZXNwb25zZT0xODMxNTU0OGM3ZjNhMzdlNzE2ZmE4ZTkwZGZhYjliNixxb3A9YXV0aA== + cnNwYXV0aD1mZWNiMzZiNzA4NmUwYjk1ZDkwNjQ1OWVmYThjYzI5ZQ== | |
| REPLY +OK Login successful | |
| </servercmd> | |
| <data> | |
| From: me@somewhere | |
| To: fake@nowhere | |
| body | |
| -- | |
| yours sincerely | |
| </data> | |
| </reply> | |
| # | |
| # Client-side | |
| <client> | |
| <server> | |
| pop3 | |
| </server> | |
| <features> | |
| !SSPI | |
| Debug | |
| crypto | |
| </features> | |
| <name> | |
| POP3 DIGEST-MD5 authentication | |
| </name> | |
| <command> | |
| pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user:secret | |
| </command> | |
| </client> | |
| # | |
| # Verify data after the test has been "shot" | |
| <verify> | |
| <protocol> | |
| CAPA | |
| AUTH DIGEST-MD5 | |
| dXNlcm5hbWU9InVzZXIiLHJlYWxtPSJjdXJsIixub25jZT0iNTMwMGQxN2ExZDY5NWJkNDExZTRjZGY5NmY5NTQ4YzIzY2VkNjE3NSIsY25vbmNlPSIzNDMzMzIzMTM1MzMzMjMxMzYzMzMyMzEzNzMzMzIzMSIsbmM9IjAwMDAwMDAxIixkaWdlc3QtdXJpPSJwb3AvMTI3LjAuMC4xIixyZXNwb25zZT0xODMxNTU0OGM3ZjNhMzdlNzE2ZmE4ZTkwZGZhYjliNixxb3A9YXV0aA== | |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| </verify> | |
| </testcase> |