Upgrade from vscode to @types/vscode

The vscode package is deprecated and hasn't been updated in months. This
means that some of the newer/updated APIs only have correct TypeScript
annotations with the new package. This change replaces the outdated
dependency with the new one.

Change-Id: Iec3b77efff1848d591fde7168798170c86236e01
2 files changed
tree: c533d5318425b00976e77825914886dc071b0e12
  1. .gitignore
  2. .vscode/
  3. .vscodeignore
  4. AUTHORS
  5. CHANGELOG.md
  6. CONTRIBUTING.md
  7. LICENSE
  8. PATENTS
  9. README.md
  10. images/
  11. language-configuration.json
  12. package-lock.json
  13. package.json
  14. src/
  15. syntaxes/
  16. tools/
  17. tsconfig.json
  18. tslint.json
README.md

FIDL Language Support for Visual Studio Code

This extension adds syntax highlighting to FIDL files.

The syntax highlighting is generated by a script called generate-syntax.ts. That can be run by:

npm install
npm run-script build-syntax