Fix package-lock.json and update lodash to 4.17.15

This CL removes a duplicate "}," line in package-lock.json, making it
possibly to run `npm install` again. This line was probably introduced
by a bad merge.

This also updates lodash to 4.17.15 as recommended by `npm audit`,
addressing the vulnerability https://nodesecurity.io/advisories/1065.

The audit also reveals https://nodesecurity.io/advisories/813, a
vulnerability in js-yaml used by mocha. This CL does not address this
because it would mean going from major version 5 to 7 of mocha, and
mocha is not affected by this vulnerability since it uses safeLoad
(https://github.com/mochajs/mocha/issues/3880#issuecomment-484794696).

Change-Id: I87277d63dd76259dcd8c2c9246f3ec2e4fd1889c
1 file changed
tree: e6f8707b35a1ba1070f30043a5e0b9222e7f67ad
  1. .gitignore
  2. .vscode/
  3. .vscodeignore
  4. AUTHORS
  5. CHANGELOG.md
  6. CONTRIBUTING.md
  7. LICENSE
  8. PATENTS
  9. README.md
  10. images/
  11. language-configuration.json
  12. package-lock.json
  13. package.json
  14. src/
  15. syntaxes/
  16. tools/
  17. tsconfig.json
  18. tslint.json
README.md

FIDL Language Support for Visual Studio Code

This extension adds syntax highlighting to FIDL files.

The syntax highlighting is generated by a script called generate-syntax.ts. That can be run by:

npm install
npm run-script build-syntax