[pkg] Use the new deprecated_system_package alias

PKG-46

Change-Id: I6dcdf744971223ba19646daed914100b2c8dae40
diff --git a/BUILD.gn b/BUILD.gn
index 8c6d6d5..f6cccaa 100644
--- a/BUILD.gn
+++ b/BUILD.gn
@@ -75,7 +75,7 @@
 
 package("package") {
   package_name = "sqlite"
-  system_image = true
+  deprecated_system_image = true
 
   deps = [
     ":shell",