blob: c6ae7ef2cd73865014c32b0c5055a78f9ec278b2 [file] [log] [blame]
language: rust
sudo: false
matrix:
include:
- rust: 1.18.0
before_script:
# lazy_static 1.1 requires Rust 1.21+, so downgrade it.
# (we only use it in benchmarks anyway...)
- cargo generate-lockfile
- cargo update -p lazy_static --precise 1.0.2
- rust: stable
env:
- FEATURES='serde-1'
- rust: beta
- rust: nightly
- rust: nightly
env:
- FEATURES='test_low_transition_point'
branches:
only:
- master
script:
- |
cargo build --verbose --features "$FEATURES" &&
cargo test --verbose --features "$FEATURES" &&
cargo test --release --verbose --features "$FEATURES" &&
cargo doc --verbose --features "$FEATURES"