[parking_lot] Switch fuchsia to using 0.7.1

We already have 0.7.1 in our tree, but fuchsia was using the older
0.6.4 version. This switches us over to using the newer version.

Change-Id: I1af1554227373444f61da8b03d251e830ef79af9
diff --git a/rustc_deps/Cargo.lock b/rustc_deps/Cargo.lock
index e1becea..deb1904 100644
--- a/rustc_deps/Cargo.lock
+++ b/rustc_deps/Cargo.lock
@@ -524,7 +524,7 @@
  "num 0.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
  "num-bigint 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
  "owning_ref 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "parking_lot 0.6.4 (registry+https://github.com/rust-lang/crates.io-index)",
+ "parking_lot 0.7.1 (registry+https://github.com/rust-lang/crates.io-index)",
  "pest 2.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
  "pest_derive 2.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
  "pin-utils 0.1.0-alpha.4 (registry+https://github.com/rust-lang/crates.io-index)",
diff --git a/rustc_deps/Cargo.toml b/rustc_deps/Cargo.toml
index 441fafe..eff48cc 100644
--- a/rustc_deps/Cargo.toml
+++ b/rustc_deps/Cargo.toml
@@ -45,7 +45,7 @@
 num = "0.2"
 num-bigint = { version = "0.2", features = ["rand"] }
 owning_ref = "0.4.0"
-parking_lot = "0.6"
+parking_lot = "0.7.1"
 pest = "2.1"
 pest_derive = "2.1"
 pin-utils = "=0.1.0-alpha.4"