Update myst-parser requirement from ==2.* to ==3.*

Updates the requirements on [myst-parser](https://github.com/executablebooks/MyST-Parser) to permit the latest version.
- [Release notes](https://github.com/executablebooks/MyST-Parser/releases)
- [Changelog](https://github.com/executablebooks/MyST-Parser/blob/master/CHANGELOG.md)
- [Commits](https://github.com/executablebooks/MyST-Parser/compare/v2.0.0...v3.0.0)

---
updated-dependencies:
- dependency-name: myst-parser
  dependency-type: direct:production
...

Signed-off-by: dependabot[bot] <support@github.com>
diff --git a/requirements-dev.txt b/requirements-dev.txt
index aacab7b..f3303c2 100644
--- a/requirements-dev.txt
+++ b/requirements-dev.txt
@@ -10,6 +10,6 @@
 # keep synchronous to requirements-readthecocs.txt
 docutils == 0.20.*
 furo
-myst-parser == 2.*
+myst-parser == 3.*
 sphinx == 7.*
 sphinx_autodoc_typehints == 2.*
diff --git a/requirements-readthedocs.txt b/requirements-readthedocs.txt
index e143ece..d42be45 100644
--- a/requirements-readthedocs.txt
+++ b/requirements-readthedocs.txt
@@ -5,6 +5,6 @@
 # keep synchronous to requirements-dev.txt
 docutils == 0.20.*
 furo
-myst-parser == 2.*
+myst-parser == 3.*
 sphinx == 7.*
 sphinx_autodoc_typehints == 2.*