[prebuilt] Updates to cipd.py error handling

Improve error handling and messages in cipd.py.

Change-Id: I7db679f54fc3f11417a94127822194cc21008d5d
Reviewed-on: https://fuchsia-review.googlesource.com/c/infra/prebuilt/+/405395
Commit-Queue: Rob Mohr <mohrr@google.com>
Reviewed-by: Gary Boone <gboone@google.com>
1 file changed
tree: 4aea684d7e1f4ce9708054be265cda2991f771c5
  1. .cipd_version
  2. .cipd_version.digests
  3. .gitignore
  4. AUTHORS
  5. CONTRIBUTING.md
  6. LICENSE
  7. PATENTS
  8. README.md
  9. cipd.ensure
  10. cipd.py
  11. manifest/
  12. update.sh
README.md

Infra Prebuilt

This repository contains the labels of a number of prebuilt tools that are used to build work with the Fuchsia infrastructure. The actual tools themselves are located in the Chrome Infra Package Deployer (CIPD).

In most cases, the jiri tool will download the build tools automatically during its update step. To download the tools manually, run update.sh.