blob: c59faf85182b2dac5e26573e7c7596fd8e50304b [file] [log] [blame]
# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
#
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
# to registry (e.g., crates.io) dependencies.
#
# If you are reading this file be aware that the original Cargo.toml
# will likely look very different (and much more reasonable).
# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "tuf"
version = "0.3.0-beta6"
authors = ["heartsucker <heartsucker@autistici.org>", "Erick Tryzelaar <etryzelaar@google.com>"]
description = "Library for The Update Framework (TUF)"
homepage = "https://github.com/theupdateframework/rust-tuf"
documentation = "https://docs.rs/tuf"
readme = "README.md"
keywords = ["security", "update", "repository"]
categories = ["cryptography"]
license = "MIT/Apache-2.0"
repository = "https://github.com/theupdateframework/rust-tuf"
[lib]
name = "tuf"
path = "./src/lib.rs"
[dependencies.chrono]
version = "0.4"
features = ["serde"]
[dependencies.data-encoding]
version = "2.0.0-rc.2"
[dependencies.derp]
version = "0.0.14"
[dependencies.futures-io]
version = "0.3.1"
[dependencies.futures-util]
version = "0.3.1"
features = ["io"]
[dependencies.http]
version = "0.2.0"
[dependencies.hyper_013]
version = "0.13.2"
features = ["stream"]
optional = true
default-features = false
package = "hyper"
[dependencies.hyper_014]
version = "0.14.15"
features = ["stream", "client", "http1"]
optional = true
default-features = false
package = "hyper"
[dependencies.itoa]
version = "0.4"
[dependencies.log]
version = "0.4"
[dependencies.percent-encoding]
version = "2.1"
[dependencies.ring]
version = "0.16"
[dependencies.serde]
version = "1"
[dependencies.serde_derive]
version = "1"
[dependencies.serde_json]
version = "1"
[dependencies.tempfile]
version = "3"
[dependencies.thiserror]
version = "1.0"
[dependencies.untrusted]
version = "0.7"
[dependencies.url]
version = "2"
[dev-dependencies.assert_matches]
version = "1.5.0"
[dev-dependencies.futures-executor]
version = "0.3.1"
[dev-dependencies.lazy_static]
version = "1"
[dev-dependencies.maplit]
version = "1"
[dev-dependencies.pretty_assertions]
version = "1"
[features]
default = ["hyper_014/tcp"]
unstable_rsa = []